PDA

View Full Version : My internet connection got knocked out



redsmetz
12-17-2008, 10:25 PM
A little over a week ago, I downloaded an update to the free firewall program Zone Alarm. After doing that, the software's "True Vector" program stopped working on my PC stopped working. I'm running Windows Vista Home Basic.

Using my laptop, I researched on their website bulletin boards and found that I needed to uninstall the program, but the usual way wasn't working because the True Vector kept stopping. In Safe Mode, I was able to delete most (if not all) of the Zone Alarm and True Vector files, emptied the Recycling Bin and restarted. The Zone Alarm was gone, but my internet wouldn't work at all (prior to this, it would work occasionally until True Vector stopped).

When I run Windows Network Diagnostics, it tells me "the network adapter 'Realtek RTL8139/810x Family Fast Ethernet NIC' is experiencing driver or hardware related issues." Above that it says "The network adapter 'Local Area Connection' is not correctly configured to use the IP protocol."

Using a flash driver, I updated the driver for the Realtek, but that didn't solve the problem. I've searched high and low on the internet, read and re-read the Zone Alarm board (one "guru" there simply regurgitates ZA's plan and then throws up his hands and says it's hard to diagnose a computer from afar - yes, I know they're volunteers and I know that's a true statement).

I know many folks on here are very tech savvy, so I thought I'd toss it out here to you all to see if anyone has any ideas.

I know the network card is working because this laptop is connecting to the network, as is my daughter's computer upstairs.

Help!

Nugget
12-18-2008, 04:58 PM
I had a problem with my laptop resetting the value on the wireless internet card and got the same response from a whole bunch of tech support people.

You might want to reinstall the hardware through windows (if you haven't done that already) and look up the internet for stuff on "resetting network card defaults".

Good luck

IslandRed
12-18-2008, 05:12 PM
One thought, and it's just a guess based on how you described things... you said you tried to uninstall but the TrueVector kept it from finishing, then you started removing files. Is the system still attempting to run the TrueVector service? It basically puts itself in the path of all TCP/IP communication, so if it's not working right, it could have the practical effect of disrupting the Realtek card's ability to deal with the TCP/IP protocol, i.e. the error messages you're getting.

I don't have Vista so I'll describe XP and hope you can figure out how to do the same:

Control Panel -> Administrative Tools -> Services

See if the "TrueVector Internet Monitor" is listed. If the Status is "Started" or the Startup Type is anything but "Disabled," then stop the service if it's running, set the Startup Type to "Disabled" and then re-boot and see if it helped.

redsmetz
12-19-2008, 09:23 AM
Thanks for the input.

True Vector seems to be off the computer completely, but there is still one Zone Alarm file that Vista will not permit me to delete (apparently an inherent problem with Vista that is a huge circular Catch 22). That is zlavscan.dll, but I can't delete it.

With regard to reinstalling the network card, I don't know how to do that. I think I'll just call my computer guy I use here at work and get him to come in and try to fix it. After all these years of using Zone Alarm, it's shocking that they've been so unhelpful in resolving this problem they caused.